GTalarm2
Application Note: Automation

Monitoring, alarm, control, automation
This manual includes steps to install, set up and use your system.

Applications:





Features of the module GTalarm2

Large pharmaceutical warehouses
Hospitals
Small-scale pharmacies and laboratories
Small storage facilities

Monitoring solutions should incorporate a complete management system
that includes the following features:









User management;
Sensor inventory management;
Site calibration management;
Reading the sensors, installed at every site;
All sensors or tags clearly assigned to a specified location;
Management of alarm set points;
Directing alarm messages to specific individuals.
Rapid tracking of system activities.


















2G or 3G modem
4 Analog inputs (pull up 5.1K) 0-10V
2 Analog Input/ Output , 0-10V , 0-20mA
3 Digital Inputs/Outputs 3.3V , 20mA,
4 PGM outputs 24V/1000mA. Open Drain.
Up to 32 sensors, temperature, humidity etc.
* Digital expansion module BUS.
In-field firmware upgradeable via USB and SERA2 software
Events log buffer. 2048 events
Program remote controls using the master or installer codes
Up to 800 users remote controls with mob phone,
Up to 800 users remote controls with iButton or RFID keycard
Up to 800 user code. To control with Wiegand keyboard.
Built-in-real-time clock backup battery
Unlimited control via SMS.
Push button software reset

*Bus terminal can be used as digital output. There is no expansion module
function at the moment.

The meaning of icons in the manual:

Very important

Important
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1

Building monitoring, alarm system

Automated data monitoring provides reliability advantages compared to manual measurements, which rely on human intervention. It could be used for
measurement of the temperature and/or relative humidity distribution within a storage area, including identification of hot and cold spots. Temperature
sensors should be located in areas where the greatest variability in temperature is expected to occur. Temperature, humidity sensors should be positioned
so as to be minimally affected by transient events such as door opening. The advantage of the system: data recorded accurately and continuously.
Automation data monitoring system has the following technical characteristics:
Event Log

Sensors

Event Monitoring

Temperature

Continuously collect and buffer data, even during
power loss.

Analog 0-10V

Process Automation

Various sensors: temperature sensors for ambient
and refrigerated stores, sensors with remote probes
for low temperatures, temperature and relative
humidity sensors and sensors for logging events
such as door opening.

Analog 4-20mA

Alarms

Sensors could be calibrated manually.

Humidity

GTalarm2
module

Remote Control

Figure 1 The purpose of the module GTalarm2
The advantages of the system:
It is possible to connect up to 32 sensors for monitoring purpose.
Low and high threshold for output activation. Cooler, heater or other device will be
activated, before temperature goes out of range;
Sensor calibration. Temperature, humidity measuring will be more accurate and
stable over the selected range after sensor calibration.
Celsius to Kelvin, Fahrenheit conversion.
Event alarms such as mains power failure or door open. Operational events (for
example door opening in freezer rooms and cold rooms) can have a significant impact
on environmental control. Users can react earlier and the damage could be less if they
will be informed about unwanted events.
It is possible to connect to the module via Linux server. This system is user
programmable and may also be remotely monitored and controlled via Linux server.
- Events log. Events may to be logged and recorded. Up to 2048 events could be logged
to the system if more events needed, events could be logged via Linux server.

-

Hysteresis.
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Figure 2Hysteresis visualization
High and low alarm hysteresis. The module will not send events if the temperature
fluctuates in defined temperature range.
- High and low hysteresis for output activation. The module will not activate / deactivate
the temperature output, if the temperature fluctuates in defined temperature range
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1.1

General view of the module

1. Micro SIM card holder of
“Push-Push” type
2. GSM antenna connector
3. RESET button
4. Mini USB programming
connector
5. REG (yellow) see table 3
6. DATA (red) see table 3
7. WDG (green) see table 3
8. Power supply and
input/output connector
9. External microphone
connector

MIC MIC

COM

SPK SPK

Figure 4 GTalarm2 PCB Layout

Do not locate SIM card with force, because you may damage SIM card holder

1.2

Meaning of LEDs and contacts

Table 1 Meaning of LEDs
Name
WDG (green) built-in
LED

REG (yellow) built-in
LED

DATA (red) built-in LED

1.3

Indication variations
Watchdog heart beat blinking, remains lit for
50ms, and turns off after 1000ms.
Off
Lights continuously
Flashes, remains lit for 50ms, turns off for
300ms
Blinking fast, remains lit for 50ms turns off
for 50ms
Off
Lights continuously

Meaning
The module is functioning.
The module is out of order or no voltage
Modem has been registered to the network
Modem is being registered to the GSM network.
PIN code of SIM card error. PIN code request should be removed
Modem failed to register to the network.
The memory of the module contains unsent reports to the user or to the
server.

First steps to prepare GTalarm2 module and Sera2 software

Preparation procedure of the module GTalarm2.
•
Connect the GSM antenna to the antenna
connector.
•
Insert the SIM card in the SIM card holder.
Ensure that PIN request function is disabled.
•
Connect the module to the computer via
mini USB cable.

Install configuration software SERA2.
•
Go to the http://topkodas.lt/ website and download SERA2 software.
•
Open the folder containing installation of the software SERA2. Click the file
„SERA2 setup.exe“
•
If installation directory of the software is OK, press [Next]. If you would like to
install the software in the other directory press [Change], specify other installation directory
and then press “next”.
•
Check if the correct data are entered and press Install
•
After successful installation of the software SERA2, press [Finish]

Connection of the module to your PC
The module must be powered with (+12V >500 mA) voltage, it should have inserted SIM card (with replenished account and removed PIN
CODE REQUEST). Module must be connected to the PC via micro USB cable
Work with the software SERA2
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Start the software SERA2. Go to „Start“> „All programs“> „SERA2“> „SERA2 “or go to installation directory and click „SERA2.exe“.
If you are sure that the module is fully connected to PC and power supply, please go to Devices > GTalarm v2

Figure 5 The meaning of icons

Each time after configuring the module press Write 5 icon thus the software SERA2 will write configuration changes into the module!

After configuration of the module, all settings may be saved at PC. It enables to save time, when next time the same configuration will be used – it will not
be necessary again to set the same parameters. If you want to save that is already recorded by the module, firstly you must read configuration of the
module. Press Read 4 icon. In order to save configuration go to File 1 then press “Save As” or “Save”. Enter configuration parameter in the displayed
table and press „OK“
In order to start saved configuration go to File then press Open
It allows to copy the same programmed content into as many modules as required.

Power supply, Battery Wiring
AC 90-260V

GTalarm2

3

PS 12

Battery

-12V+12V
black
red
yellow

Power supply installation manual:
https://www.topkodas.lt/Downloads/TPS12_UM_EN.pdf
Do not reverce the polarity

VV+
Bat+
BatAC/N
AC OK
No Pin
Bat Low
AC/L

It is possible to supply the security system from stabilized power supply
source 10-15 V and not less than 1,5A. It is necessary to calculate max
current of power supply. The current of the alarm system is the current used
by sensors, relays, siren and other devices. It is most convenient to use
power supply source applied for power supply of security systems with the
option to connect backup lead battery. It is recommended to mount remote
control relays into sockets. Sockets may be easily fixed in metal box. It is
necessary to select relays according to preferred voltage and current.
Power supply application note:
https://www.topkodas.lt/Downloads/GTalarm2_TPS12_AN_EN.pdf
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Figure 6Power supply connection

Applications. Examples.

There is several examples of applications with temperature sensor DS18b20 and temperature, humidity sensor AM2320. The same AM2320 sensor could
measure temperature and humidity.
The DS18b20 digital thermometer provides 12-bit Celsius temperature measurements. The DS18b20 communicates over a 1-Wire Each DS18b20 has
a unique 64-bit serial code, which allows multiple DS18B20s to function on the same 1-Wire bus. Thus, it is simple to use one to control many DS18b20s
distributed over a large area. Applications that can benefit from this feature include HVAC environmental controls, temperature monitoring systems inside
buildings, equipment, or machinery, and process monitoring and control systems.
Temperature and humidity combined sensor AM2320. It is digital temperature and humidity sensor is a digital signal output has been calibrated. Using
special temperature and humidity acquisition technology, ensure that the product has a very high reliability and excellent long-term stability. Ultra-small
size, low power consumption, signal transmission distance up to 20 meters, making all kinds of applications. Applications: HVAC, dehumidifiers, testing
and inspection equipment, consumer goods, automation, data loggers, gas stations, home appliances, humidity control, medical, and other relevant
humidity measurement and control.

3.1

Single sensor control

Input D1 on the module measures the temperature of a chamber or oven with
a temperature sensor. Control loop takes feedback directly from the input D1
and signals output OUT1 on the module to switch the heater that heats the
chamber or oven accordingly.

The signal from the input is used as feedback to the control algorithm.

The signal from the output controls the heater by signaling when the
heater should be ON for ON – OFF control or how long it should be on.

Enter names for inputs, outputs to make the application easier to
understand.

Sensors calibration possible

GTalarm2

D1

Out 1

Chamber or Oven
DS18b20
temperature
sensor
Heater

Figure 7 Single loop control
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3.2

Heat and cool control loop

Input D1 on the module measures the temperature of a chamber with a
temperature sensor. Control loop takes feedback directly from the input D1
and signals output OUT1 on the module to switch the heater that heats the
chamber and OUT2 to cool the chamber as needed.

The signal from the input D1 is used as feedback to the control
algorithm.

The signal from the OUT1 controls the heater by signaling when the
heater should be ON for ON – OFF control or how long it should be on.

The signal from OUT2 controls cooling by signaling, when the chiller
should be ON.

Enter names for inputs, outputs to make the application easier to
understand.

Sensors calibration is possible

GTalarm2
D1

Out 1

Environmental Chamber
Out 2
Chiller

DS18b20
temperature
sensor
Heater
Figure 8 Heat and cool control loop

3.3

Process Alarm

Input D1 on the module GTalarm2 measures the temperature of a chamber or
oven with a temperature sensor. GTalarm2 monitors the temperature from the
input D1, which is also used by the control loop as feedback for heat control.
When the temperature goes out-side the normal range defined by the useradjustable, alarm set points, OUT1 energizes an audible alarm and an indicator
lamp to get the operator’s attention.

The signal from Input D1 is the one the GTalarm2 monitors against the
alarm set point.

The signal to the output indicates when the alarm has occurred. The alarm
message could be send to the user in case of temperature alarm whether
or not there is an output attached

The output could drive external devices as shown in this example.

Enter names for inputs, outputs to make the application easier to
understand.

Sensors calibration is possible

If output activation in case of alarm events is needed, please configure
required parameters in "Sensors/ Automation" window.

GTalarm2

D1

Out 1

Chamber or Oven

Out 2
Indicator Lamp

AM2320
humidity,
temperature
sensor
Alarm Buzzer

Figure 9 Process Alarm
If Indicator lamp and alarm buzzer is needed, please refer to the “Fire and Security system” application note.
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3.4

Temperature, humidity control

The temperature and humidity of an environmental chamber are controlled by
two loops. Loop1 uses a heater to increase the temperature and cooling coil
to lower the temperature. Loop2 uses a solenoid to control water to flow to an
atomizer to raise the humidity and a dehumidification coil to lower the humidity.
To minimize wear on the compressor and use of electricity, the compressor is
turned OFF and ON by the controller’s output for compressor control.

The signals from the temperatures and humidity loops’ determine when
the temperature, humidity loops need the compressor to be on.

The signal from OUT signals when to turn on the compressor.

To save power and extend the life of the compressor, it is desirable for
the compressor to be off when it is not needed. The need for the
compressor is anticipated by monitoring the inputs.

Delay times could be set.

Enter names for inputs, outputs to make the application easier to
understand.

Sensors calibration is possible.

Set the hysteresis parameters long enough to protect the compressor
from too much cycling, but short enough to allow the compressor to turn
OFF between uses.

GTalarm2

Environmental Chamber

Out 4

Dehumidification Coil

Out 3

Atomizer

Out 2

Cooler

Out 1

Heater

D1

AM2320 humidity,
temperature sensor

Figure 10 Temperature, humidity control

3.5

Ventilation control

Out1

Out2

GTalarm2 controller

D1

D2

D3

The kitchen ventilation requirement is based on the intensity of the use of the equipment (the cooking equipment is never all at once in the 'cooking mode')
The module GTalarm2 was designed to be on one automatic, continuous and extremely smooth way respond to current situations without human
intervention and to be applicable in all possible ways business scenarios in kitchens.
-

When the kitchen is not in operation, the module GTalarm2 stop the ventilation or to continue with a low capacity to maintain good hygiene during
inactivity. The fans and control valves are automatically set to the minimum air flow settings.
When the unit in on operation, the module GTalarm turns on the ventilation. The control valves and fans are set to the maximum air flow settings.
The control valves and fans could be controlled depending on temperature or humidity sensor’s values.

GTalarm2 Application Note: Automation
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HVAC control. Switch from min to max airflow
Temperature and humidity sensor. The same sensor can measure temperature and
humidity. It is possible connect up to 3 temperature- humidity sensors to the D1, D2, D3
inputs.
The house ventilation requirement is based on the intensity of the use of the equipment. The module GTalarm2 was designed to be on one automatic,
continuous and extremely smooth way respond to current situations without human intervention and to be applicable in all possible ways scenarios in the
house.
-

3.6

When the kitchen is not in operation, the module GTalarm2 stop the ventilation or to continue with a low capacity to maintain good hygiene during
inactivity. The fans and control valves are automatically set to the minimum airflow settings.
When the unit in on operation, the module GTalarm2 turns on the ventilation. The control valves and fans are set to the maximum airflow settings.
The control valves and fans could be controlled depending on temperature or humidity sensor’s values.

Multiple sensors application. Smart house.

Multiple temperature sensors. It is possible to
connect up to 32 temperature sensors to the
module GTalarm2.

Temperature- humidity sensor. The same
sensor can measure temperature and humidity.

PIR movement detection sensor.

Magnetic contact.
Up to 32 sensors could be connected to the module GTalarm2.
Up to 32 temperature sensors could be connected to the same input.
Up to 3 temperature- humidity sensors could be connected to D1, D2, D3 inputs.
Up to 6 outputs could be used for device control purpose.

0-10V voltage sensor

4-20mA current sensor.

Heating control. It is possible to switch ON or
OFF heating device.

HVAC control. It is possible to switch HVAC to
minimum or maximum air flow.

Barrier control. It is possible control the barrier
up or down from mobile phone.

Garage door control. It is possible control the
garage door up or down from mobile phone.

GTalarm2 Application Note: Automation
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Various types of sensors could be used with the module GTalarm2. It is possible to connect to the module GTalarm2 on any web-enabled device to see
you sensor data, set alarms, customize text alerts, etc. Types of sensors:

The Temperature and Humidity Sensor is used to measure atmospheric temperature and humidity in indoor environments. Useful in server and
clean rooms, humidors, museums, industrial spaces, greenhouses, and heating and ventilation applications.

The Temperature (Thermistor) is used to measure temperature in freezers, HVAC units, on pipes and in liquids.

The Motion Detection Sensor is used to detect movement within a specific area. Motion detection sensors are frequently used in security and
energy management applications, among others.

The Dry Contact Sensor is used to detect the opening of a door. Useful in warehouses, real estate, cottages, second homes.

The 4-20ma current sensor is used to measure the current in sensors, probes or other devices.

The 0-10 volt sensor is used to accurately measure charge - or voltage - for up to 10 Volts across two wires. Useful for measuring output from a
variety of sensors, probes and devices.
It is possible to control devices, connected to the outputs of the module GTalarm2. For example:

Set the HVAC system to the minimum or maximum airflow.

Control automatic gates.

Turn ON or OFF heating device.

3.7

3.7.1

How to control heating or cooling device with the module GTalarm2

How does smart thermostat, alarm system works?

The module will keep the home at a stable temperature

Figure 11 The controller will turn ON/ OFF heater, depending of the
temperature
„Min Value To Activate Output“ temperature is great for helping
prevent home from going below certain temperatures by turning on
heating when the set limits are reached. Turn off the heating, when
comfort zone is reached.

The smartphone will alert user if there are unusual temperature changes
at home.

Figure 12 The controller will send alarm SMS and call to the user if the
temperature will reach alarm value
„Min Value Alarm“ temperature can prevent the pipes from freezing, even if the
heating system is broken. The module GTalarm2 will inform the user (send alarm
SMS and call)

Temperature control system relies upon a controller, which accepts a temperature sensor as input. It compares the actual temperature to the desired
control temperature, or set point, and provides an output to a control element. An on-off controller will switch the output only when the temperature crosses
set point. For heating control, the output is on when the temperature is below the set point, and off above set point. Since the temperature crosses the set
point to change the output state, the process temperature will be cycling continually, going from below set point to above, and back below.

GTalarm2 Application Note: Automation
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Figure 13 how does smart thermostat, alarm system works?

3.7.2

How to prevent the output from frequently changes according to minute temperature changes

ON/OFF control action turns the output ON or OFF based on the set point. The output frequently changes according to minute temperature changes as a
result, and this shortens the life of the output relay or unfavorably affects some devices connected to the Temperature Controller. To prevent this from
happening, a temperature band called hysteresis is created between the ON and OFF operations.
In cases where this cycling occurs rapidly, and to prevent damage to contactors and valves, an on-off differential, or “hysteresis, “is added to the controller
operations. This differential requires that the temperature exceed set point by a certain amount before the output will turn off or on again.

Figure 14 The example of configuration. Sera2> Automation/ Sensors. Double click on the selected line.

Max Value hysteresis is the same hysteresis for Output activation and for alarm event.

GTalarm2 Application Note: Automation
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3.7.3

The example of heating, cooling control with the module GTalarm2

Figure 15The explanation of hysteresis
The module activates the output at the set point. The event recovers from the hysteresis value.
Temperature 28 degrees – OUT1 will be activate after 1000ms. „Max Alarm Event
Delay“prevents from OUT1 activation in response to short-term temperature fluctuations, for
example because of window or door opening.
Temperature 30 degrees –alarm SMS with the text “Max Value” will be send after 10000ms
If the hysteresis set to 1. The system will work as follows:
Set point = 28 degrees
When temperature rise to 28 degrees, turn on the cooler. When temperature drops to 27 degrees,
the system will turn off the cooler.
Figure 16 The example of sensor's setting

ON- OFF control switches the output either full ON or full OFF, depending on the input set point and hysteresis values. The hysteresis value indicates the
amount the process value must deviate from the set point to turn on the output. With hysteresis set to 0, the process value would stay closer to the set
point, but the output would switch ON and OFF more frequently, and may result in the output “chattering”.
In order to control big power alternating current equipment, it is comfortable to use solid state relays.
AC/DC adapter with the voltage 10V - 14V and current >=1A might be used to powering the module. We recommend to use TPS12 power supply with
the deep discharge protection. The solution with GTalarm2 module will gives a call and send SMS warning when the battery voltage reaches the limit.
https://www.topkodas.lt/Downloads/TPS12_UM_EN.pdf
https://www.topkodas.lt/Downloads/GTalarm2_TPS12_AN_EN.pdf
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GTalarm2
Cooling device
+3.3V
D1
D2
D3
COM
IN1
IN2
IN3
IN4
I/O1
I/O2
OUT1
OUT2
OUT3
OUT4
BUS
COM
VD+

Heating device

AC 85-260V
DC 85-260V

SSR output

Solid state relays

+

-

5-24V Input

~
-

~

~

+

SSR output

~

DC 10-14V, >1A

Temperature sensor
DS18b20

5-24V Input

+12V
Cooler control Out1

Fuse 5A

Heater control Out2

Figure 17 the example how to control heating or cooling device with the module GTalarm2

3.7.4

Change the room temperature remotely via mobile, web app

Up to 32 app based thermostats in one module –allow to control a thermostat using mobile, web app. Module GTalarm2 will let control, change the room
temperature remotely

Please refer to the “Android, web app” user manual: https://www.topkodas.lt/Downloads/GTalarm2_App_AN_EN.pdf

3.7.5

Change the room temperature with SMS text messages

This application is useful when the area where the controller located is in a cellphone service, but there is no internet access. For example: the cabin in
the mountains. This solution will allow to send an SMS/text message to remotely turn up the thermostat, ahead of time, so that it's warm when the customer
will arrive.

GTalarm2 Application Note: Automation
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Commands can be given in two different ways: the first one is to send the SMS according to required syntax and with the password (if required), needful
to avoid strangers to operate the configuration

Multiple temperature sensors. It is possible to connect up
to 32 temperature sensors to the module GTalarm2.
Temperature- humidity sensor. The same sensor can
measure temperature and humidity.
Heating control. It is possible to switch ON or OFF heating
device.

INST000000˽070˽N#VALUE #

INST000000˽071˽N#VALUE #

INST000000˽072˽N#VALUE#

INST000000˽073˽N#VALUE#

Programming of max sensors value upon reaching, the SMS message with „High Alarm“ text will be sent
070= command code (max sensors value upon reaching which, the SMS message with „High Alarm“ text will be
sent)
N = sensor number
VALUE= Format 0000.00 High Alarm Value
Programming of minimal sensors value upon reaching the SMS message with „Low Alarm“ text will be
sent
071= command code (min sensors value upon reaching which, the SMS message with „Low Alarm“ text will be
sent)
N = sensor number
VALUE = Format 0000.00 Low Alarm Value
Programming of sensor max value upon reaching the selected output will be activated. For example cooling
equipment
072= command code (sensor max value upon reaching the selected output will be activated.)
N = sensor number
VALUE= Format 0000.00 sensor max value upon reaching, the selected output will be activated.
Programming of sensor min value upon reaching the selected output will be activated. For example heating
equipment
073= command code (sensor min value upon reaching the selected output will be activated.)
N = sensor number
VALUE= Format 0000.00 Sensor min value upon reaching which, the output will be activated.

GTalarm2 Application Note: Automation
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4

Sensors. Inputs.

4.1

Steps to start humidity sensors DHT22/AM2305/AM2306/AM2320/AM2321

Module should work with following sensors: Aosong 1-Wire bus Humidity Sensor DHT22, AM2305, AM2306. Also a new smaller sensor exists AM2320 &
AM2321.
Table 2 Sensors AM2320/AM2321 specification
Manufacturers' Specification
AM2320/AM2321
Operating Range

0–100

Absolute accuracy (%RH, 25°C)

±3% (10-90%); ±5% (<10, >90%)

Repeatability (%)

±0.1

Long term stability (% per year)

0.5

1/e Response (sec)

5

Voltage supply (V)

3.1–5.5(AM2320); 2.6–5.5(AM2321)

The table lists values taken from datasheets. The Aosong data sheets do not specify maximum tolerances for most parameters, just 'typical' values. It
would therefore seem that any particular device is not guaranteed to meet these specifications. For all the other devices the numbers above are the
maximum tolerances and most also offer better 'typical' specifications.

SD A

COM

3

D3

D1

2

D2

+3.3V

1

SC L

Each AM2320 sensor connects on separate bus line to digital inputs (D1, D2, and D3). Total up to 3 AM2320 Aosong (Guangzhou) humidity sensors can
be connected to GTalarm2

4
GND

VC C

D1, D2, D3

AM2320

Figure 17 AM2320 connecting diagram

Steps to start AM2320 sensors:
1. Connect AM2320 to D1, D2, D3 according connection diagram.
2. Sensor’s type should be select in the System Options> Digital I/O Settings window.
Set digital input definition D1, D2, D3 to Aosong 1 Wire bus Humidity Sensor AM2320
3. Write configuration
4. Power module.
5. After module starts , read configuration
6. Go to “Automation/ Sensors” window in the SERA2 software
7. Double click on the selected sensor’s line.
8. Click on “Sensor type/ hardware location” and default sensor settings appear.
9. In sensors table column Sensor HW ID find registered sensors AM2320 looks like
"GTalarm, Input D1, 1-Wire, AM2320 Huminidty, 28AE51560500" Location of the sensor
can be changed choosing wanted sensor in the list
10. Double click on the sensor row opens selected sensor window
11. Set other parameters of the sensor MIN, MAX values Units etc.
12. Write configuration to module
13. Open RT Testing&Monitooring Window > Hardware. Press [Start monitoring] button
14. Go to RT Testing&Monitooring Window > Event Monitoring TAB. Software will show
real time sensor values, and alarm states
15. If you need to receive SMS with sensors alarm, go to GSM communication> SMS/
DIAL Reporting window
16. Enter telephone numbers of users and mark alarm events that you want to receive.
Open "Reporting SMS&DIAL" window. Set user phone number, and choose reporting
option Sensor1 - Sensor32 Alarm/Restore. Module will send SMS to user in case of
sensor alarm event
17. Write configuration

Do not reverse the polarity

GTalarm2 Application Note: Automation
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Humidity sensor watchdog

The sensor restarts when the system recognizes sensors not being processed for some
time. If the sensor will not communicate with the module more than the programmed time
(for example 2min), the system will reset the sensor. It is the way to ensure the stable
work of the system, because the sensor will be reset if needed. For this purpose any of
OUT1-OUT4 can be used.

GTalarm2
+3.3V
D1
D2
D3
COM
IN1
IN2
IN3
IN4
I/O1
I/O2
OUT1
OUT2
OUT3
OUT4
BUS
COM
VD+

4.1.1

The output should be configures as sensor reset:
Go to “Outputs” window.
Set “Out definition” to “RH Sensor trouble”, “Mode” – “Steady”.

1234
AM2320

V

COM

VD+

OUT4

Step by step to start analog sensors:
BU S

OUT2

OUT3

I/O2

OUT1

IN4

I/O1

IN2

IN3

COM

IN1

D2

D3

+3.3V

Steps to start analog sensors, connected to the inputs 0-10V, 0-20mA, 4-20mA
D1

4.2

Humidity sensor AM2320
1 VCC
2 SCL
3 SDA
4 GND

A

0-10V

4-20mA

Figure 18 Analog sensor connection

+3.3V
D1
D2
D3
COM
IN1
IN2
IN3
IN4
I/O1
I/O2
OUT1
OUT2
OUT3
OUT4
BUS
COM
VD+

GTalarm2

1. Connect analog voltage sensors to In1, In2, In3 and connect analog current sensors to I/O1,
I/O2 according connection diagram.
2. Security system sensors, could be used in the system, if required.
3. If security system sensors is not in use, the inputs should be disabled in “Zones” window.
4. Analog sensors should be calibrated in the Automation/Sensors window. Double click on the
selected sensor’s line. Analog sensors could be selected from the default list. Units could be
changed. Sensors calibration is possible by changing multiplier, offset.
5. When all changes has been done, the configuration should be written, by pressing “Write” icon.
6. Open RT Testing&Monitooring Window > Hardware. Press [Start monitoring] button
7.Go to RT Testing&Monitooring Window > Event Monitoring TAB. Software will show real time
sensor values, and alarm states
8. If you need to receive SMS with sensors alarm, go to GSM communication > SMS/ DIAL
Reporting window. Enter telephone numbers of users and mark alarm events that you want to
receive. Open "Reporting SMS&DIAL" window. Set user phone number, and choose reporting
option Alarm/Restore. Module will send SMS to user then sensor alarm event occurs
9.Write configuration
There is the possibility to convert Celsius to Fahrenheit or vice versa, or calibrate the sensors
measuring.
Two point is the simplest as the equation is y=mx+c. It is the equation of a straight line, the graph
of a linear sensor. Y is the output value, m is the multiplier otherwise known as the slope or
gradient and c is the offset. X is the input value.
Go to “Automation/ Sensors” window and double click on the selected sensor’s line.

PT100 / 4-20 mA

PT100
Figure 19 PT100 connection
Figure 20Sensor calibration area

Figure 214-20mA sensor connection with
12V system

GTalarm2 Application Note: Automation

Figure 224-20mA sensor connection
with 24V system
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4.3

Steps to start temperature sensors DS18b20.
Do not reverce the polarity

The DS18b20 digital thermometer provides 12-bit Celsius temperature measurements. The DS18b20 communicates over
a 1-Wire Each DS18b20 has a unique 64-bit serial code, which allows multiple DS18b20s to function on the same 1-Wire
bus. Thus, it is simple to use one to control many DS18b20s distributed over a large area. Applications that can benefit
from this feature include HVAC environmental controls, temperature monitoring systems inside buildings, equipment, or
machinery, and process monitoring and control systems.
Applications/Uses






Consumer Products
Industrial Systems
Thermally Sensitive Systems
Thermometers
Thermostatic Controls

Key Features

Measures Temperatures from -55°C to +125°C (-67°F to +257°F)

±0.5°C Accuracy from -10°C to +85°C

Each Device Has a Unique 64-Bit

Figure 23DS18b20 sensor

1.

Connect 1-Wire sensors DS18b20 to D1, D2, D3 according connection diagram.

Figure 24DS18b20 connection with long distance UTP or FTP cable
2.

If you need to connect more sensors to the same input, connect them as a star. In order to compensate line impedances, each line should be
separated by 82-120 Ohm resistors.

The resistor must be as close as possible to the contacts of the module GTalarm2.
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82-120 Ohm

max 100m line

82-120 Ohm

max 100m line

VD+

COM

BUS

OUT4

OUT3

OUT2

OUT1

I/O2

I/O1

IN4

IN3

IN2

IN1

COM

D3

D2

D1

+3.3V

GT alarm2

Sensor1 DS18b20
Sensor2 DS18b20

82-120 Ohm

max 100m line
Sensor3 DS18b20

Figure 25Star connection
3.
4.
5.
6.
7.
8.
9.

10.
11.
12.
13.
14.
15.
16.

Sensor’s type should be select in the System Options> Digital I/O Settings window. Set digital input definition D1, D2, D3 to Dallas 1-Wire Bus
option.
Write configuration by pressing write icon.
Power module.
After module starts , read configuration
Go to “Automation/ Sensors” window in the SERA2 software
Double click on the selected sensor’s line.
Click on “Sensor type/ hardware location” and default sensor settings appear. In sensors table column Sensor HW ID find registered sensors
DS18b20 looks like "GTalarm2, Input D1, 1-Wire, DS18B20 Temperature, SN:28AE51560500" Location of the sensor can be changed choosing
wanted sensor in the list.
Double click on the sensor row opens selected sensor window. Set other parameters of the sensor MIN, MAX values Units etc.
Write configuration to module
Open RT Testing&Monitooring Window > Hardware. Press [Start monitoring] button
Go to RT Testing&Monitooring Window > Event Monitoring TAB. Software will show real time sensor values, and alarm states
If you need to receive SMS with sensors alarm, go to GSM Communications > SMS DIAL Reporting window. Enter telephone numbers of users
and
Mark alarm events that you want to receive. Open "Reporting SMS&DIAL" window. Set user phone number, and choose reporting option Sensor1
- Sensor32 Alarm/Restore. Module will send SMS to user then sensor alarm event occurs
Write configuration

How to identify sensors, connected to the inputs?
Sensors could be connected one by one and write the serial number and the name of the sensor. Each sensor has a name, it is entered in SERA2 in the
“Automation / Sensors” window.
If all sensors connect at the same time, they will be registered in random way. If the sensors are connected to the star and if you want to know where the
sensor is, then you can raise the temperature of the one sensor and see where the sensor is located. Let's say, the temperature of all sensors is 10
degrees, the temperature of one sensor is raised to 20. Look to the Sera2> RT Testing&Monitoring“> Sensors/Automation window and you will see to
which input the sensor is attached
1-Wire Network Topologies
1-Wire networks are often quite "free form" in structure, they usually fit into a few generalized categories, based on the distribution of the 1-Wire slaves
and the organization of the interconnecting wires.
-

Linear topology. The 1-Wire bus is a single pair, starting from the master and extending to the farthest slave device. Other slaves are attached
to the 1-Wire bus with insignificant (< 3m) branches or "stubs."
Stubbed topology. The 1-Wire bus is a single main line, starting at the master and extending to the farthest slave. Other slaves are attached to
the main line through branches or stubs 3m or more in length.
Star topology: The 1-Wire bus is split at or near the master end and extends in multiple branches of varying lengths. There are slave devices
along, or at the ends of, the branches.
Linear topology.
Stubbed topology.
Star topology:
Sensors DS18b20

Sensors DS18b20

5

GTalarm2 module

GTalarm2 module

1

2

3

4

2

>3m stubs

5

GTalarm2 module

1

2

3

4

3

1

5

Figure 26 Wiring linear topology

Sensors DS18b20

4

Figure 27 Wiring stubbed topology
Figure 28 Wiring star topology

When different topologies are intermixed, it becomes much more difficult to determine the effective limitations for the network. As a rule, the designer
should apply the most conservative of the criteria in these cases.
Using cat 5 cable is best and will make it easier to maintain a working 1-wire network when you expand and add more sensors. The data and ground
should use one twisted pair, for example blue/blue-white. A single wire from another pair is used for the 3.3 volt supply.

GTalarm2 Application Note: Automation

18 | E N

Don't double up wires on the assumption that this lowers resistance and is a 'good thing', it actually alters the impedance of the network and makes it less
reliable. All unused wires in the cat 5 cable should be left unconnected (don't connect them to ground).When running a 1-Wire bus, Dallas recommend that
you use an unshielded Cat5 cable for the bus. Do not use shielded cable as the capacitance increase will upset the network.
If you intend to have a large 1-Wire network, it is important that you design the network correctly, otherwise you will have problems with timing/reflection
issues and loss of data. You must connect each sensor to a single continuous cable which loops from sensor to sensor in turn (daisy chain). This will
reduce potential miss-reads due to reflections in the cable. Each sensor should have a maximum of 50mm (2") of cable connected off this main network.
Even when using this method, connecting more than 10-15 sensors will still cause problems due to loading of the data bus. To minimize this effect, place
a 100-120Ω resistor in series in the data line of each sensor before connecting to the network. The total length of the bus from 10 to 100m. Depending of
cable quality sensors number on bus, and environment noise. There is possibility to connect up to 32 devices.

VD+

COM

BUS

OUT4

OUT3

<100m

100 Ohm
100 Ohm

100 Ohm

<100m

OUT2

OUT1

I/O2

I/O1

IN4

IN3

IN2

IN1

COM

D3

D2

<100m

<2m

Sensor6 Sensor7 Sensor8
DS18b20 DS18b20 DS18b20

Sensor9
DS18b20

If 1 or 2 temperature sensors connected to
the module GTalarm2 resistors are not
required. However, if the sensors are
combined
with
different
topologies,
separation of 82-120Ohm resistors is
required. Different topologies must be
separated through 82-120Ohm resistors.
The resistors must be connected as close as
possible to the contacts of the module
GTalarm2.
If the sensors do not work properly, noise is
generated, we recommend connect 4702000uF capacitors as showed in the figure
below.
The capacitor is connected at the end of the
line as close as possible to the sensor.

Sensor5
DS18b20

Sensor2
Sensor4
DS18b20
DS18b20
Sensor3
DS18b20
Figure 29DS18b20 sensors connecting to the module GTalarm2 when different topologies are intermixed

Sensor
DS18b20
+
470-2000 uF

dat a

Sensor1
DS18b20

D1

+3.3V

GT alarm2

Figure 30 Capacitors connecting to the
sensors
Begin the installation by mounting additional devices in the cabinet using the stand-offs provided, then mount the cabinet in a dry, protected area with
access to unstitched AC power. Install hardware in the sequence indicated in the following pages. Do NOT apply power until installation is complete.

Minimum ¼” (6.4mm) separation must be maintained at all points between power limited and non-power limited wiring and connections.

5

How to identify sensors, connected to the inputs?
1.
2.

You can connect sensors one by one and write the serial number and the name of the sensor. Each sensor has a name, it is entered in
SERA2 in the “Automation / Sensors” window.
If you connect all sensors at the same time, they will be registered in random way. If the sensors are connected to the star and if you want to
know where the sensor is, then you can raise the temperature of the one sensor and see where the sensor is located. Let's say, the temperature
of all sensors is 10 degrees, the temperature of one sensor is raised to 20. Look to the monitoring window and you will see where the sensor is.
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Figure 31Sera2> RT Testing & Monitoring > Sensors/ Automation

6

Figure 32Sera Cloud Android App

Low and high alarm threshold settings. Output activation.
Sera2> Automation/ Sensors. (Double click on the line)
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If In1…In4 or I/O1…I/O2 inputs are used then
1. Go straight to the Automation/ Sensors window.
2. Select the sensor
3. Set High/ Max Value Action Settings
4. Set Low/Min Value Action Settings.

If Digital inputs D1, D2, D3 are used, then
1. go to System Options> Digital I/O Settings and select required parameters
2. Press “Write” in the command line.
3. Power the module
4. Press “Read” in the command line
5. Go to Automation/ Sensors window
6. Select the sensor
7. Set High/ Max Value Action Settings
8. Set Low/Min Value Action Settings.

More information:
4.2
Steps to start analog sensors, connected to the
inputs 0-10V, 0-20mA, 4-20mA

More information:
4.1
Steps to start humidity sensors DHT22/AM2305/AM2306/AM2320/AM2321
4.3
Steps to start temperature sensors DS18b20.

Temperature 28 degrees (Max Value To Activate Output)
OUT1 (Output) will be activated after
1000ms (Max Value Output Control Delay)
Temperature 30 degrees (Max Value Alarm Event/ SMS)– alarm SMS
With the text “Max Value” (Alarm Event SMS Text)
Will be send after 10000ms (Max Alarm Event Delay)
Max Value Hysteresis=1
When temperature rise to 28 degrees, turn on the cooler
When temperature drops to 27 (28-1) degrees, the system will turn off the cooler.

5. When all changes has been done, the configuration should be written, by pressing write icon.
6. Open RT Testing&Monitooring Window > Hardware. Press [Start monitoring] button
7.Go to RT Testing&Monitooring Window > Event Monitoring TAB. Software will show real time sensor values, and alarm states
8. If you need to receive SMS with sensors alarm, go to GSM communication > SMS/ DIAL Reporting window. Enter telephone numbers of users and
mark alarm events that you want to receive. Open "Reporting SMS&DIAL" window. Set user phone number, and choose reporting option Alarm/Restore.
Module will send SMS to user then sensor alarm event occurs
9.Write configuration

7

Every field explanation in Sera2> Automation/ Sensors window

Double click on the selected sensor’s line will show selected sensor’s configuration window.

2

3

4

28

6

16

7

17

8

18

14

24

13

23

11

21

25

Figure 33 the example of Automation/Sensors (Automation/Sensors/Analog Inputs) window
For example double click on “Sensor Name 1” line will show “Sensor 1 Settings” window. The required parameters of the sensor 1 can be set in that
window.
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1
2
3

4
5
6
7
8
9
10
11

12
13
14
15
16
17

18
19

25

26

20
21
22
23

27

24
Figure 34 the example of Automation/Sensors (Automation/Sensors/Analog Inputs) window
Table 3 Explanation of every field in "Automation/ Sensors" window
Sensor name
Sensor Name
2
Select the sensor type hardware location
Location of sensor connected to the module. Select connected sensors
Sensor disabled
GTalarm, Input IN1…IN4, 0-10V
Voltage input IN1… IN4, 0-10V assigned
GTalarm, Input I/O1…I/O2, 0-10V
Voltage input. I/O1…I/O2 0-10V assigned
Sensor Type/
GTalarm, Input I/O1…I/O2, 0-20mA
Current I/O1…I/O2 , 0-20mA assigned
3
Hardware location= Sensor Hardware ID
GTalarm, Input D1…D3, 1-Wire
Digital input D1…D3, 1-Wire DHT22 RH,
DHT22 RH, Humidity
Humidity assigned
GTalarm, Input D1…D3, 1-Wire
Digital input D1…D3, 1-Wire DHT22 RH,
DHT22 RH, Temperature
Temperature assigned
1-Wire Temperature sensors
Digital input D1…D3, 1-Wire DS18b20
Temperature sensor
Sensor Unit Text
Sensor Unit Text= Unit
4
Maximum allowable temperature value, which will be reported.
6
Max Value Alarm Event/ SMS= Max Val SMS
Maximum allowable temperature value, which will activate the selected output
Max Value To Activate Output= Max Val OUT
7
Temperature hysteresis value is indicated.
Max Value Hysteresis= Max Hyst
8
……………
Max Alarm Event Delay= Max SMS Delay
9
Max Value output Control Delay= Max OUT
……………
10
Delay
The output which will be activated, when the maximum allowable temperature value will
Output= Max OUT
11
be reached
Report Contact ID code
Contact ID Report Code= Max CID
12
Text, which will be visible in SMS message in case of set temperature excess, is
Alarm Event SMS Text= Max Alarm SMS
13
entered.
The indicated report will be sent when it is checked.
Enable Alarm Event/ SMS= Max SMS en
14
Minimum allowable temperature value, which will be reported.
Min Value Alarm Event/ SMS= Min Val SMS
16
Minimum allowable temperature value, which will activate the selected output.
Min Value To Activate Output= Min Val OUT
17
Temperature hysteresis value is indicated.
Min Value Hysteresis= Min Hyst
18
……………
Min Alarm Event Delay= Min SMS Delay
19
Min Value Output Control Delay= Min OUT
……………
20
Delay
The output which will be activated, when the minimum allowable temperature value will
Output= Min OUT
21
be reached
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22

Contact ID Report Code= Min CID

23

Alarm Event SMS Text= Min Alarm SMS

24

Enable Alarm Event/ SMS= Min SMS en

25

X-multiplier= Mult Coef Correction

26

Y-offset= Sum Coef Correction

Report Contact ID code
Text, which will be visible in SMS message in case of set temperature excess, is
entered.
The indicated report will be sent when it is checked.
X-multiplier coefficient. Following the equation “Temperature=X*ADC+Y“to calculate X
and Y coefficients. Measure temperature in two points at least.
Y-offset coefficient. Following the equation “Temperature=X*ADC+Y“to calculate X and
Y coefficients. Measure temperature in two points at least.

Temperature= X*ADC+Y
Contact ID Report Code= Max CID

Max and Min Contact ID report codes. Report codes are the Ademco CID, SIA DC09
format. The module can automatically program a set of default report codes. The
Contact ID Reporting Format can be modified and changed. Enter any of the desired
Contact ID Report Code= Min CID
22
text in the “Alarm SMS Text” field.
After the connection to the module and after clicking on a read icon the real time value
RT Value
/28
of the sensor will be displayed in this field.
Fig ilustrate how to calculate X-multiplier and Y-offset with excell chart.
12

8

How to calibrate the sensor

Following the equation Temperature=X*ADC+Y, selecting X and Y coefficients.
1.
2.
3.
4.

Go to Sera2 software, Automation/ Sensors window, double clicked on the selected sensors line.
Measure temperature at least in two points with the accurate thermometer.
Read temperature ADC indications at these points in the “RT Testing & Monitoring” > “Sensors/ Automation” window.
Following the equation “Temperature=X*ADC+Y“to calculate X and Y coefficients. Calculated X and Y coefficients should be programmed in the
module. It is easy to calculate X and Y coefficients in MC Excel by using trend line.

Figure 36 Sensor Calibration area in
Sera2> Automation/ Sensors (double click
on the sensor’s line)
Figure 35ilustrate how to calculate X-multiplier and Y-offset with excell chart.

9

How to convert Celsius to Kelvin or Celsius to Fahrenheit

Sensor Calibration area in Sera2> Automation/ Sensors (double click on the sensor’s line)
1. Go to Sera2> Automation / Sensors
Celsius to Fahrenheit conversion
(double click on the sensor’s line).
Y(offset)=32, X(multiplier)=1.8
2. Enter Y (offset) and X (multiplier) values.
Celsius to Kelvin conversion
3. Change the units to Kelvin or Fahrenheit
Y(offset)=273.15, X(multiplier)=1
in the Sera2> Automation/ Sensors
(double click on the sensor’s line).

GTalarm2 Application Note: Automation
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Sera2> Automation/ Sensors (double click on
the sensor’s line)
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10 Outputs.
Sera2> Outputs (PGM)
GTalarm2 comes equipped with four open-collector PGM outputs allowing to connect up to four devices or relays. Also GTalarm2 comes with two
programmable 20mA outputs, three 10 mA and max voltage 3.3V outputs, and with one 20mA programmable output BUS.
If the output is not in used, it should be disabled. Once a PGM output is disabled, it can no longer be turned ON or OFF unless it is enabled again.
It is possible to instantly turn ON an individual PGM output for a determined time period and automatically turn it OFF when the time period expires. When
the PGM output is turned ON or OFF, the system will send a confirmation by SMS text message to the user phone number

1.
2.
3.
4.
5.

VD+

BU S

COM

OUT3

OUT4

OUT1

OUT2

I/O1

I/O2

The automatic action of the determined PGM output can be set as
follows:
Turn ON – Determines whether the PGM output is to be turned
ON.
Turn OFF – Determines whether the PGM output is to be turned
OFF.
Pulse – Determines whether the PGM output is to be turned ON
or OFF for a set period of time in seconds based on the PGM
output startup state set up.

6.
7.
8.

The PGM output can be automatically activated under the following
events:
System armed or disarmed
Alarm begins or stops
Zone violated, or restored.
The user can also set a custom text, which will be sent by SMS text
message to user phone number when the automatic PGM output action
is carried out.

Install SERA2 software.
Connect the module to the computer via mini USB cable.
Go to Outputs (PGM) window in the SERA2 software
Parameters of the selected output should be set:
output operation description (OUT definition): disable, bell, buzzer, flash, system state, ready,
automation/ CTRL, AC OK, battery OK, ARM/ DISARM, alarm indication, lost primary channel, lost
secondary channel, fire sensor, RH sensor trouble.
State type: flash, timer, steady mode.
If necessary output operation might be inverted.
Write configuration by pressing write icon

NO
Outputs can be controlled only in Automation/ CTRL mode.

com

If you need to control outputs by short call or SMS, go to “Users & Remote Control” window and enter
telephone numbers of users, who will be able to control selected outputs via free short call.
10. Write configuration by pressing write icon
9.

NC
Fig. 1 Relay connection to OUT1-OUT4,
I/O1, I/O2 20mA




For sound and visual signaling, please refer to Fire and Security application note.

In order to control big power alternating current equipment, it is comfortable to use solid state relays.
Standard AC/DC adapter with the voltage 10V-14V and current >=1A might be used to powering the module.

Figure 37 The example of Outputs window
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Table 5 Explanation of every field in "Outputs" window
Output sequence number.
ID
1
Output Location
The outputs hardware location.
2
in Hardware
Output name
Output Label
3
Selection of output operation mode.
Output disabled
21 Disable
Remote control by call mode is enabled. Output designed for connection of
4
Out definition
27 Remote Control
electrical devices which will be controlled by SMS message or phone call
Output for RH Sensor trouble operation. In this mode output can automatically
35 RH Sensor Trouble
reset Humidity sensor if trouble occurs.
Output control mode.
Steady ON/OFF mode
36 Steady
5
Mode
Output ON pulse mode
37 Timer
Pulse time duration can be from 1 to 999999 sec.
Out Timer
6
Inversion is activated
Invert
7
Pulsating mode is activated. Then output is activated it will pulsate according pulse ON/OFF time.
Pulsating
8
Pulsating mode pulse ON duration.
Pulse ON Time
9
Pulsating mode pulse OFF duration.
Pulse OFF Time
10

Output ON

Outputs can be set as timers.

1.
2.
3.

When output is activated for “Out Timer” time
interval,
Relay contact start changing state from ON (pulse
time ON) to OFF (Pulse time Off)
This cycle will repeat until output is deactivated.

Output state

Output OFF
Pulse time ON

Pulse time ON

Output signal

Pulse time OFF

Pulse time OFF

11 Power loss alarms.
If power loss, or other troubles should generate alarm to the users, please refer to the Fire and Security application note

12 Alarm events such as open doors
If operational events such as door opening may also need to be logged and recorded, please look to the fire and security system’s application note. This
information is useful because operational events (for example door opening in freezer rooms and cold rooms) can have a significant impact on
environmental control.

13 Remote monitoring, control, configuring, FW updating over the internet
If remote monitoring, control, configuring, FW updating over the internet is needed please refer to the “Remote monitoring via Linux Server” application
note.

14 General system configuration
Sera2> System Options> General System Options
The system comes equipped with internal real-time clock (RTC) with battery that keeps track of the current date and time. Once the system is up and
running, the user must set the correct date and time, otherwise the system will not operate properly. SERA2 software provides the ability to select the
Time Zone and The user may also choose Set module time from PC, which instantly provides the exact PC time. When the system is connected to the
monitoring station via IP connection the date and time will be automatically synchronized with the monitoring station.
If the module has been connected first time to the power supply, or power supply has been disconnected for a long time, the time of the
module should be set again.

The module can send a trouble report and restrict arming if some of selected troubles [Restrict ARM] exist during close event.
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Figure 38 the example of System Options > General system Options window.
Table 6 Explanation of every field in "General System Options" window
1
Object Name
SIM card PIN code. Default 1234
2
SIM Card PIN
The default installer password is 000000. This password allows you to enter programming mode, where you can
3
Installer Password
program all features, options, and commands of the module.
The default SMS User Password is 123456. This code allows you to utilize arming method, as well as program
4
SMS User Password
user codes.
User Access Code
A 4-digit or 6-digit user access code format can be selected.
5
Format
2-Wire Smoke detector (Fire current loop) or 0-10V Analog Input (Zone or Sensor) or Output or – 0-20mA, 46
I/O1 Settings
20mA Current Loop Sensor could be assigned to the I/O1
2-Wire Smoke detector (Fire current loop) or 0-10V Analog Input (Zone or Sensor) or Output or – 0-20mA, 47
I/O2 Settings
20mA Current Loop Sensor could be assigned to the I/O2
0-10V Analog Input
0-10V Analog sensors will be connected to the input
15
(Zone or Sensor)
Input will be used as output
16
Output
2-Wire Smoke Detector
2-Wire Smoke detectors will be connected t the input.
17
(Fire current loop)
0-10mA, 4-20mA Current
0-20mA, 4-20mA Current Loop Sensors will be connected to the input.
18
Loop Sensor
Clear Event Buffer After
When the cell is checked, the memory of unsent reports will be deleted after the module resetting
8
Reset
26
Set module time from PC To set the clock click Set time from PC button and the clock will be set using computer’s clock.
To read the clock of panel.
27
Read module time
28
PC Time
29
Panel Time
Reset module command
14
Reset Device
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15 Logging events
Sera2> Events Log
The Event Log window show real time information of the events that has been occurred. Every enabled new event is stored in log. Internal event log has
some limitations. It is possible to store 2048 events in the events log buffer. Events could be saved to the file. If you need to store more events, you can
use Sera cloud server. The user is able to see every event remotely via web app.
The event log allows to chronologically register up to 2048 time stamped records regarding the following system events:






System start.
System arming/disarming.
Zone violated/restored.
Temperature deviation by MIN and MAX boundaries.
Configuration via USB.

Figure 39 How to find required Events Log window.

Figure 40 the example of the Events Log window.
Table 5 explains every field in the Events Log window.
Table 7 Explanation of every field in "Events Log" window
Read Event Log
Events could be read from the module by clicking Read Event Log button
1
Clear Event Log
Events could be cleared from the module by clicking Clear Event Log button
2
Event Number
Event sequence number
3
Event
Object number and registered event report in Contact ID code.
4
Time
Event date and time.
5
Note
Event report text which was indicated.
6

15.1 Event monitoring
Sera2> RT Testing & Monitoring> Event Monitoring
The following information is displayed:

Figure 41 The example of RT Testing & Monitoring > Event Monitoring window
Table 8 Explanation of every field in "Event Monitoring" window
…
Event number
3
CID
Contact ID Code
4
Time
Event date and time
5
Note
Event report text which was indicated.
6
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15.2 Monitoring Inputs, outputs & general system info
Sera2> RT Testing & Monitoring> Hardware
RT „Testing & Monitoring” window „Hardware“ tab enables you to view and test the current status of each input, output

1

2

14
15
16
17

3
4
5
6
7

18

19
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20

21
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24

34

25

35
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36

27

37

28

38

29

39

30

40

31

41

32

42

33

43

23

9

10
11
12

13

Figure 42 The example of RT Testing & Monitoring > Hardware window
Table 9 Explanation of every field in "Hardware" window
Pressing Start Monitoring button starts the monitoring of the module.
1
Start Monitoring
Pressing Stop Monitoring button stops the monitoring of the module.
Stop Monitoring
2
IMEI number of GSM modem available in the module
IMEI
3
ICCID (Integrated Circuit Card Identifier) - A SIM card contains its unique serial number (ICCID).
SIM
ICCID
4
ICCIDs are stored in the SIM cards and are also printed on the SIM card.
If note READY is visible, it means that SIM card is fully functioning. Otherwise, check whether PIN
5
SIM Card
code request is off or replace SIM card.
Signal strength of GSM communication
Signal level
6
State of GSM modem registration to GSM network.
Registration
7
SMS center number. This number should be checked if it is correct. If this number is incorrect. SMS
SMS Service Centre
8
messaging may be impossible. This number may be changed after inserting SIM card into any mobile
Address
phone.
Power supply voltage. Nearby number is value of ADC voltage. When multiplying this number by the
9
System Voltage
coefficient Fig. 32, voltage value (V) will be achieved.
System voltage OK/Trouble
System Voltage
10
Real time clock OK/Trouble
RTC Clock
11
Indicates the time of the module RTC
Module Real Time Clock
12
By pressing this button real time clock of the module will be set.
Set RTC Clock
13
In1…In4 is the indicated input ADC and voltage value V.
14-17
Inputs In1…In4
I/O1…I/O2 is the indicated voltage ADC value and current ADC value mA.
I/O1…I/O2
18-19
Check box nearby the digital inputs D1…D3 (I/O) means that the input has ‘0’ or ‘1’ state.
D1…D3 (I/O)
20-22
Check box nearby the programmable output BUS (I/O) means that the input has ‘0’ or ‘1’ state.
BUS (I/O)
23
Checked box nearby the appropriate output Out1…Out4 means that this output currently has ‘0’ or ‘1’
Out1…Out4 On/Off
24-27
state. The output could be activated by pressing On/Off button
Checked box nearby the appropriate input/output I/O1…I/O2 means that this input/output currently has
I/O1…I/O2 On/Off
28-29
‘0’ or ‘1’ state. The output could be activated by pressing On/Off button
Checked check box nearby the digital outputs D1…D3 (I/O) means that the output currently has ‘0’ or
D1…D3 (I/O) On/Off
30-32
‘1’ state.
Checked check box BUS (I/O) means that the output currently has ‘0’ or ‘1’ state.
33
BUS (I/O) On/Off
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15.3 Realtime Testing & Monitoring > Sensors/ Automation
Sera2> RT Testing & Monitoring> Sensors/ Automation

1

2

3

4

5

Figure 43 the example of RT Testing & Monitoring > Sensors/ Automation window
Table 10 Explanation of every field in "Sensors/ Automation" window
Sensor number
1
Sensor1…Sensor32
The value of sensor’s voltage
Value
2
If checked and the color is green, the sensor is active
Active
3
If checked and the color is red, the high value alarm is generated
High Val Alarm
4
If checked and the color is red, the low value alarm is generated
Low Val Alarm
5
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